CPU properties - Time synchronization (NTP)- not working

Hi there! In my home project I am trying to setup time synchronization on X20CP1584, but I am failing. It does not get synchronized. What I am doing wrong? I do not see any error in AS.



And of course PLC has internet access.

I checked AS help, but it seems that it does not help.

Thank you!

Hi,

please check if DNS service is activated in the PLC’s properties - DNS is needed to resolve the time servers IP address from the given domain name.
Also, please check if the’re any logger entries (I assume warnings) about the time service.

Hi Alexander,

now I have activated DNS service (just that).
In logger I do not see any warnings. And still does not work.
image

Thank you!

Hi Andrej,

if you’re using the PLC as DHCP client, then I recommend to setup “Get DNS from DHCP server” to “on”… normally, the DHCP server also provides the DNS server (often, the DHCP server is also the internet router, and acts as DNS server).

If you’re using the PLC with a static IP address, then you have to setup at least one DNS server manually under “DNS server addresses - Server 1”. DNS servers can only be given as IP address (because the DNS server it that one who resolves the domain names), you can use for example 8.8.8.8, which is a Google DNS server.

But be aware, you also have to setup the default gateway of the PLC, because if no default gateway is configured the PLC cannot communicate outside of the local network (not only a PLC, but every IP network system uses the default gateway to route network packets to outside the local network).

Here, a short example of the needed parameters to configure, if using static IP adress (PLC doesn’t act as DHCP client) but needing a internet connection with DNS.

This is the network which my notebook is connected to:

image

So, I have to setup:

  • a static IP address out of my network which is not already in use (ETH IF configuration)

  • the default gateway of my network, and a DNS server (CPU configuration)

The usage of 192.168.168.1 as DNS server would also work in my example, because my internet router (= the default gateway) also acts as a DNS server for the local network… but of course, this depends on the internet router hardware.

Yes! Now it works.

Thank you @alexander.hefner

Hello @Kolma

I have marked the post from Alexander as solution as you confirmed in the previous post that this helped you getting the topic solved.

1 Like