Error during built : Failed to built compound widget

I have a project that was running fine for a while. All of a sudden today after starting my PC in the morning i opened the project and suddenly got like 50 error messages, mappview plus xml related. I have tried to rebuilt the project but still this comes up (see attachment). So i have tried a different project that has a compound widget with a different AS version and i got the same result. So my conclusion is this is some Microsoft windows problem with XML files and it only happens for projects with compound widget in them. Has anyone seen this before? any help or tips will be appreciated. Thanks

Hello Mahadi,

can you try to delete Binaries and Temp folder in AS project after closing project?
Does it work when you reopen the project?

Maybe there is a problem with your virus.
Try to delete Binaries and Temp and reopen while your Antivirus is disabled.

Hope this helps you.

Greetings Simon :slight_smile:

1 Like

Hi Simon,

I have tried that but the issue is still there. I have copied that same project to a private PC and there is no problem there, i am able to build the project completely with no error. So for me all indication is my work PC is the issue. but i could not figure out what went wrong between Friday and Monday. By the way i also could not open mappview pages where compound widgets is instantiated,(error is: The object cannot be loaded) everything else is fine.


could you please try to start Automation Studio as administrator (right click on the AS icon → run as administrator), does the behavior change?

Best regards!


If Alexander’s idea doesn’t help, I suggest trying to reinstall AS. It might be faster than investigating what’s wrong with your installation or configuration. Jaroslav

1 Like

Hi All,

yesterday i tried uninstalling AS and installing again , that didn’t help neither. So i had and today i got the latest version “” and run it as administrator and now everything seems fine, the error is gone and i was able to compile the project. it is a bit weird because now i am even able to open older project done with AS4.9 and that was not possible yesterday. Anyways, thank you all for your input and suggestions, that actually really helped

happy for you Mahadi :slight_smile:

1 Like


Nice that’s working now for you. If this appear again, here is few things to check :

  • Did you edit compoundwidget file with external text editor ?
  • Check encoding type of the xml file
  • Check EOL (End of line) type (CRLF / LF)

My guess is that xml file was changed from something, compilation call microsoft XML library to parse this file, maybe this library version didn’t handle correctly EOL LF or maybe some encoding of file.

Hope it can help !