Transfer Eth configuration as DHCP server

Hello there, helpful members of the B&R Community,

I created an empty project to commission a new sensor and connected to my controller whose ip I already knew ( However, since I just opened my project, my IP Adress mode was selected as DHCP Server in my ETH configuration and I transferred the project in this way. Now I cannot reconnect to the controller and it does not show up when I try to boot. I wonder if anyone has encountered such a problem before, can you help?

If you misconfigured the ETH port of your PLC it is suggested to set the system to BOOT. Then the PLC gets its IP address from a DHCP server (or

See also : B&R Online Help

1 Like

Also, I highly recommend making sure that SNMP is activated in the Ethernet configuration that you’re showing. This allows you to browse for the target and set its IP address from Automation Studio’s Online->Settings window. You may want to turn this off before you finish the project, but it’s helpful for scenarios like this where you “lose” the controller’s IP address. Just remember to set all of your IP settings before your next transfer!

As you can see in the photo, I booted it but I still can’t connect. I can’t see anything new in Online → Settings.

Did you press “Refresh”?

And as always, you can create a USB Stick with a program install. Don’t forget to select “Initial transfer” when installing from BOOT.

make sure that you are in BOOT mode and not in service mode.
BOOT mode: Press the reset button for less than 2 seconds.
Then press the reset button for longer than 2 seconds.

if you press the reset button only once briefly, the X90 will boot in service mode

After many attempts I don’t know how it was fixed, but I was able to boot and I stayed on this screen while transferring my project whose content was completely empty, and the controller is constantly clicking, as if it is constantly restarting itself, but there is nothing in the project. I only defined the controller.

This happens if you only transfer the runtime (only for X90CP154) - the plc is in a boot loop now. You have to set set it to BOOT mode again and then you have to check “Transfer with modules”.

Thank you very much Patrick! It is worked for me.

1 Like