AS connection problem

Hi community.

I have a problem with connecting my AS to the PLC.
AS version: SP
The project is empty (1 task, 1 counter) and freshly generated CF.

Everything is set up correctly:

  • fixed IP address
  • subnet
  • SNMP protocol activated

My computer sees PCs on the network - verified via command line and ping function.
My colleagues’ computers see the plc and can connect via AS.

I enter Browse in AS → Online → Settings. The search takes a long time and does not find plc. If I add the address manually and click on connect it freezes AS.

I have tried reinstalling AS. I have tried reinstalling windows 10. I have installed all the updates on the drivers.

Can anyone advise me what could solve my problem?

Hi, colleague of mine had similar problem. And for him was just enough to uninstall and install PVI again. Besides that you can check NPCAP, should be enabled on your network interface.

1 Like

Are you using a company firewall? If so, is there a possibility, that both computers are configured differently and therefore yours is blocking comunication with non-Windows hosts?
I would suggest trying to disable the FW for this instance.

Can you ping the PLC via cmd?

Additional note: PVI can be downloaded from the B&R website here.

I’d put my hand in the fire that I’ve tried this option in the past. Anyway, I installed the latest version and so far it’s working.

1 Like