Cpu x2p cp1484 does not connect online

I have an X20 CP1484 CPU that I cannot connect online. I would like to know the hardware.

I know the IP of the cpu, I also have the network adapter on my PC in range with the CPU but I notice that the Ethernet network LED blinks very little on both the PC and also the ETH LED on the CPU which remains green without blinking or very little.

The power supply I use to power the CPU is 24 volts DC and only 77 watts.

Could this be the problem?
Could the problem be that the external power supply is very small at 77 watts and does not drive the CPU?

cpu led:
Green R/E
RDY/F off
Be green
PLK off
Fixed green ETH
CF green
DC red

Sending screenshot.

Always grateful for any help.


can you PING the ip address of the PLC from Windows command line?
If ping is unsuccessful, also Automation Studio is not able to connect to the PLC.

I think it’s unusual, that ETH led is permanently on. For me, that points a bit into the direction of a network infrastructure topic.
How the PLC is connected to your notebook? Via a switch, or directly per cable between PLC and notebook? If directly, do you use a ethernet crossover cable (I’m not 100% sure, but as I remember, the X20CP1484 doesn’t have auto-negotiation on the ethernet interface)?
Could you please try if the behavior changes using different cables, or a different switch?

Best regards!

Hello Alexander.

You’re right, I ping in cmd and I don’t get answers from Plc.

I use a network cable from my laptop directly to Plc but I don’t get an answer.

The cable used is the one I use to connect to the internet via router and it works correctly, I have internet with that cable on a laptop, as a test.

On the other hand, if I use the same cable to ping the plc from cmd, I don’t get an answer, and if I look for target browswer refreshing, I don’t get anything either.

When I make an e-connection of the ethernet cable I notice that the LED flashes and everything seems normal, but it immediately returns to the fixed green state without blinking.

Should this cable have a special cross or something like that?


If the x20 cp1484 does not have automatic communication with the ethernet interface, does this mean that there is no way to connect online with the plc?

Can’t ethernet cable be used to work with a remote VNC server with ethernet cable?

Or do you want to use another type of crossover cable?


Does the cp1484 have an ethernet interface?


first of all: I’m not completely sure if it’s the root cause of your issue, but it sounds a bit like that. So I’ll try to explain:

the’re two different types of RJ45 ethernet cables: straight and crossover.
That means, in straight cables the send and receive data lines are connected to the same pins inside the cable, while in crossover cables the send and receive data lines are crossed.

Most often, straight cables are used - i think, also you’re using a straight cable.
If 2 “endpoint devices”, like notebooks, PLCs and so on, should be connected directly together, the communication lines inside the cables have to be crossed.
Most actual devices are supporting therefore a functionality called “auto MDI-X”, which means that they detect the type of connection and they’re crossing the lines automatically if needed (this is a hardware functionality of the ethernet chipset) - but not all of the devices do support this functionality.

The easiest way to test would be:

  • connect both devices to a switch, with straight cables
  • if they then can communicate, the cause was / is the direct connection using a straight cable
    • in that case, you have to use a RJ45 cross-over cable for direct connection between those 2 devices

Best regards!

Yes, the IF2 is a standard ethernet interface.


I’d like to give my input additionally:

a) are we sure of the PLC’s IP Address? Jst double checking
b) The IP Address I can see in the screenshot looks like one assigned manually (which is good, since the default is “DHCP server” and thus a direct connection would not work either, since there is no DHCP server running (usually) on a local computer). Is your laptop’s network interface configured to be in the same IP range using the same subnet mask? Otherwise the PLC can also not be pinged or connected to

Happy easter!

1 Like

Hello again.

I get a little lost.

I have tried to connect with a direct straight cable to the plc and with a direct cross cable to the plc and in both ways I do not have satisfactory results.

I have also tried the connection with two straight cables through a switch and the result is the same I can’t connect.

I certainly know the IP of the plc and the subnet mask, in tutorials I have seen that this is done in the network center/change options of the adapter/protocol Tp4/enter manual ip address in range with the plc and the same subnet, in this way I put my pc in range with the plc, correct me if I’m wrong. Maybe here comes the problem, in the way I use the network adapter of my pc, I don’t know.

To be honest, I don’t know where the problem is.

I guess you won’t have anything to do with the source codes to connect you to the online plc, I ask?

Greetings, and I am always grateful for any help.


thanks for trying out the whole cable stuff, at least we can exclude that from the list of possibilities for causing the issue.

Not having the sources of the PLC should not be the cause why you can’t connect. Of course, the developer can also deactivate the ethernet interface on the PLC completely so that the system even isn’t pingable, but I think in > 99% this is not done.

Can you please provide screenshots of the output of the following 2 Windows commands:

  • ipconfig /all
  • route print

This would be helpful to check your notebooks ethernet settings, thanks!

Best regards!

Hi @electrofasa21, it could be that IP address of the PLC is not one you think it has. I would connect your laptop with PLC directly with ethernet cable and I would try browse functionality of Automation Studio (it is available in Online Configuration), maybe you will be lucky and it will find your PLC. Not sure how your CF card was generated, but could be that there is default AR loaded and default IP address is set. Try it :slight_smile:


The online connection appears but it does not connect.


ip config

Captura de pantalla 2024-03-29 181849

route print

I imagine that the Ethernet port is enabled because it is used for an Ethernet panel and it worked, I think that the developer did not encode the Ethernet port because there was a panel working on that port.


okay, IP settings and routes on the notebook look good so far I can see.

In your last ping screenshot, I don’t understand what’s printed out there - could you please translate it? I’m asking because no matter if ping works or not, most often a standard ping delivers 4 identical lines of information, so it could be interesting why the status change without changing anything else?

Could you also please try what Jaroslav mentioned, in Automation Studio - Online - Settings, browse for targets?
It’s not sure if the function is activated or not inside the project, that depends on several factors.
But we should try at least, maybe we’ve luck?

Best regards, and have a nice weekend!

The last capture:
-ping 192.168.250. 10 (PLC)
-Reply from (PC): destination host unreachable
-Timeout for this request
-Ping statistics for (PLC):
-Packages sent 4
-Received 1
-Lost 3
-(75% lost)

I have also performed the card search as Jaroslav said online/setting/browses for targets and it cannot be found, I am sending a screenshot

I don’t know if anything more can be done about it.

Always grateful for any help, a little blocked.


unfortunately I’ve no more idea what to test to find out the cause without trying out a different PLC of the same type, a different PC and so on. Where I’m very sure about is, as long as we can’t ping, we don’t have to concentrate on the Automation Studio online settings.

If possible, I would try:

  • setting up a “dummy” AS project onto a 2.nd CF card (I’m sure you won’t overwrite the existing one) and check if you can get an online connection - this would help to understand if we’re having a hardware issue.
  • trying to connect with a different PC - you already know that your ethernet interface works, but nevertheless there could be some “incompatibility issue”
  • check again the information about the IP address of the system with the developer who should know (maybe it’s worth to mention, that also the Powerlink Interface IF3 can also be set up as a 2.nd ethernet interface - that’s not a standard setting, but it’s possible and I mention it because at least in theory the developer could have be setup 2 different IP networks on the 2 interfaces IF2 and IF3).

If you have a CF card reader for your PC, you could create an image of the CF card using Runtime Utility Center and provide that image to your local B&R support, maybe they can support you by investigation.
As you maybe know, all content on the CF card are binary modules only, but maybe the support has some more ideas what to check or where to have a look into (if you create such a image, you’re welcome to send me a message via Community, and I’ll provide you a link to a data exchange platform where you can upload the image - I have no idea right now if I can figure out more then already discussed, but at least I would try to).

Best regards!


In fact I have 2 PLCs, identical 1484 (same cf card for both), these two PLCs 1484 have in common period of inactivity (months) and the same cf card that I try in both.

Both PLCs were connected by the IF2 (ethernet) to a third-party panel (BEIJER), everything worked correctly until the panel broke down and became unusable and obsolete, and now from time to time I use them to test from time to time with them, while they are without electricity supply.

Yesterday I tried to connect to the second PlC also 1484 without success, same anomaly and same leds, in state and without online connection.

I know that these two PLCs have the same IP because the supplier left them like this because they govern 2 identical processes and if we had problems with the hardware tomorrow we would only have to exchange hardware and the SCADA (third-party) control of the plant would not notice it and thus order spare parts.

To all this, right next to it I have another newer CP 1584, and I have saved the backup with Runtime Center both the project of the 2 CP, s 1484 and also the project of the cp1584 (newer), both projects are identical, just change the version of CP 1484 and CP1584, I would like to do the following:

-Restore the cf card of CP 1484 with the copy of the cf card of CP1584

And so try to see if I connect online with the CP, 1484, because the cp1584 I am connected right now to a remote PC using VNC VIEWER, and I know your IP I also have proof that it works.

I don’t know what he thinks of all this before I restore,

Any help is good.


an image of a CP1584 unfortunalety won’t work in a CP1484, because the hardware and the operating system is not compatible to each other, and so the CP1484 won’t even boot.
I’ll keep thinking about, if and what else we could do, and will come back again later :wink:


A) So the only way I have to transfer a “manique project” is through a new cf card?

B) Can I create a “mannequin project” on my cf card to test by putting a new IP?

C) Can a “mannequin project” be transferred without the online option (ethernet) and without the cf card?

If it really works with another new IP and “maniqui project”:

Would it be enough to restore the original project on the cf card?

Many doubts, greetings and grateful.