SDM diagnostic connection ok, ONLINE/SETTING/BROWSING FOR TARGETS connection the driver does not appear

Hello.

My x20cp1484 now connects to the system diagnostic manager using the chrome browser.
I have created my own IP in a simple project (I have only configured the x20cp1484 CPU, the IP and activated SNMP), I have transferred it offline to my CF card using card reader.

I insert the created card into my x20cp1484 cpu, I open my project and the hardware is there, I have a connection with AR 3.10, RUN status.

I have installed these 2 updates:
https://www.br-automation.com/en/downloads/software/automation-studio/hw-upgrades/v40-hw-upgrade-x20cp1484/

https://www.br-automation.com/en/downloads/software/automation-studio/ar-upgrades/v40-ar-upgrade-i0310-x20cp1484/

This other update doesn’t let me install it because it is for AS V4.0 V0 4.9 and I have 4.12

https://www.br-automation.com/en/downloads/software/automation-studio/ar-upgrades/v40-ar-upgrade-i0310-x20cp1484/

Why can’t my controller be found so I can connect/disconnect in ONLINE/SETTING/BROWSING FOR TARGETS?

However, it maintains connection and I see the status and configuration in SDM in any browser.

Is it some data in the project configuration?

Where can I look?

Greetings, always grateful.

Hello

the X20CP1484 does not have enough resources (CPU) to run any type of drives.
-Yes, it has POWERLINK, and
-Yes, Automation Studio ALLOW to configure the ACOPOS and perform that type of topology
-and, YES, the compiler does not provide any type of error.

So, what is the mainproblem, the CPU is too slow to handle, and then to show in the SDM.

Why i know it?

:man_factory_worker:it happened to me also… :sweat_smile: :rofl:

By the whay the CPU is obsolete…try to upgrade.

Is the Activate SNMP setting on the IF2 Ethernet interface activated?
This setting is needed for Browse For Targets.

Hola Marcos,

Entonces si la CPU del x20cp1484 es lenta,

What should I do to correct that slowness and be able to connect/disconnect without having to close/open the ASv4.12 program?

I don’t quite understand why my x20cp1484 doesn’t connect online with ARv3.10 once my project is opened. It slows down the tasks of transferring project or other tasks, because I have to leave AS and re-enter to be in the RUN state.

Connecting/disconnecting does not work once the project is opened.

And yet in system diagnostics “http:///sdm” in the SDM browser your connection is successful.

Regards.

SNMP is activated, in fact my CPU is displayed in the browser when I start "htpp:///sdm and I can see its status.

But nevertheless from AS v12 online/setting/browsing for targets it can’t find my controller, all the time looking without finding it and I can’t then connect/disconnect to perform tasks for example online or offline.

My solution is to force close AS v12 and reopen it and only then AR v3.10 connects.

But this is not normal.

Regards.

Hello

1-Simplify you project. Just Run the CPU empty, with no drives, no tasks.
I hope you can see the SDM, and connect via Automation Studio.

If it works… then
2-You can include additional hardware, IOs and tasks. BUT forget to include the ACOPOS

If it works… Then
3-The Drives ACOPOS will never work with this CPU. Upgrade the CPU to X20CP1684

Hello,

1- I don’t have ACOPOS, I don’t have it configured either, at the moment I don’t need it.

2-I only have configured in a simple “maniki project”, without tasks or anything, only the hardware x20cp1484, no I/O, nothing.

3-Connection to SDM, yes, I have it, I have always had it.

4- What I don’t have and I can’t do is connect/disconnect from AS 4.12 to the controller through online/setting/browsing for targets.

I can only connect by forcibly closing AS and reopening it, it’s a problem.

From online/setting/browsing for targets the controller is not found. :thinking:

SNMP is activated.

Regards.

Please check if you have your PVI manager activated on your PC you can do it by looking for this simbol image on the window tasks
image

if you don’t have it activated, then actiavte it by searching PVI manager on your computer like

something like this will open
image

Then stop the service and start again
image image

1 Like

Hello,

I think my problem is due to the fact that when I search online for my controller in online/setting/browsing for targets, it happens that PVI manager disconnects, the controller does not find it and PVI manager stops.

You Wenbo are on the right track, it happens that I search for my controller online/setting/browsing for targets then the search for my controller begins, shortly after PVI manager goes to stop state, it continues the search for my controller in offline mode and this is when The search ends without success, the controller is not found and PVI manager remains in STOP state.

After all this I need to open PVI monitor and press start manager again to get PVI manager working again, and even without finding my controller I can now connect/disconnect from my x20cp1484.

What I don’t understand is what setting I need so that when I run online/setting/browsing for targets PVI manager it doesn’t disconnect and my controller appears?

If you know why this happens I would appreciate the information.

All the best.

Hi,

could you please check if the PVI manager is installed as service?
You can see when opening “Options → PVI Registry changer” at the checkbox at the bottom.

If it’s checked, could you please uncheck it, restart PVI manager, and have a look if the behavior changes?

Best regards!

Hi @electrofasa21,

I tried to reproduce the issue with a clean new AS4.12 installation and a X20CP1484, but on my test system, everything including search for PLC worked as expected.

So I’m relatively sure, there’s something “damaged” in the Automation Software installation on your system, or some security mechanisms like antivirus, code execution prevention, insufficent user rights or similar functionality prevent the “search for plc” function.

To figure this out, could you please go trough the following test?

FIrst, I recommend to reinstall PVI in the actual version.
PVI setup is part of the PVI Development Setup which can be downloaded here in the actual version 4.12.5.34.
It’s sufficient to install it with default setting activated, please ensure that “Install PVI Manager as service” is unchecked! I want to ensure that PVI manager is installed as process, not as service.


Are there any error messages / popups shown while installation?

Second, it would be very interesting if PVI manager is stopped directly after startup, or stops after using “search for plc”. Th check this, please close all open windows inside Automation Studio project first, especially the “online → settings” window (closing the windows prevent that after re-opeing the project, the windows are opened automatically and function “search for plc” starts automatically).
After closing closing all project windows, please close Automation Studio. Then, open it again without opening anything else inside Automation Studio, then open the PVI Monitor (the PVI Manager window) → is PVI Manager already in “stop”, or does it more look like in the following screenshot?

Third, leave the PVI window open, and execute a “search for plc” in Automation Studio → is the PVI manager now stopping immediately?

If not and it works now as expected, we’re done here, no need to have a look in the following information!

But if the behavior is still the same, it could be interesting to get an information of some software versions installed on your system.
Please check if you have a folder “npcap” inside your windows “programs” folder, and provide us the version of “npcap.sys” (right click → properties) … don’t wonder if your version is different to the one from the screenshot below, this is possible and could be ok, I’m only interested in the version number in general.


Also, please provide us the version of “brsnmp.dll” inside the PVI installation folder (by default, it’s C:\BrAutomation\PVI\V4.12\Bin).

And last but not least: please check your antivirus- and code execution prevention-systems and the windows event logs for messages pointing into the direction that some functions / installations were prevented / suspressed!

To be honest, I’ve no more other idea why the function doesn’t work on your system, but on my systems it works flawless using exactly the same software and hardware setup.

Best regards, and have a nice weekend!

1 Like

Hello Alexander,

You have been of great help to me, I greatly appreciate the last answer you gave me.

I have reinstalled PVI again without errors.

Now PVI manager is launched as a background process

Also PVI monitor and PVI manager are launched as a user, both coinciding.

Now I can find my X20CP1484 controller in AS 4.12 from online/setting/browsing for targets.

The problem that you have solved for me, as you explained well, is to open PVI manager automatically in process mode, never in service mode. I could see how PVI manager was previously running in SYSTEM service mode and PVI monitor in service mode.

In this way tag browsing does not work, I could also see in services such as PVI manager.exe it was executed as SERVICE.
Now PVI manager no longer appears as a SERVICE. It does not appear in the list, this is correct. I could see before that it did appear, but not anymore.

Además la configuración de PVI manager por defecto es la adecuada.


Captura de pantalla 2024-04-14 135909

I want to thank you once again for your contributions and explanations, without them I would not have achieved it.

Thank you and have a great weekend.

All the best.

1 Like

Hi,

Great to hear that it’s running now, I’m happy that I could help!

Best regards!