Error while transfering project to X20CP0482 CPU

I wrote a short test program for a X20CP0482 CPU. While transferring the code with AS to the CPU, AS stopped with this error message:

Operation canceled
\LOG CANNOT_EXECUTE_COMMAND: There is already an object in "ASCpuObject_500151250.Modules" which has the same name! Use a different name and the same address or use the object from "ASCpuObject_500151250.Modules".

Parameter name: artransfer
OK   Hilfe   

I did not find any information about this error. The only solution was to reset the PLC and do an offline installed with an USB stick.
Now the PLC is on again but I do not have an idea why this error occurred and how to resolve this error without clearing the PLC memory?

Any ideas how to solve this issue?


without having more data it’s hard to say, but as the “parameter name: arstansfer” is pointed out, I looks a bit like that the last transfer of software modules and so on was not finished yet before starting the new transfer…

Is it possible that the last transfer before that message occured was not finished, for example “transfer stuck at around 80% and was canceled by user”? If yes this could be the reason.

Normally it should not happen that a transfer doesn’t get finished, but I’ve seen such behavior for example when some “endless loops” or “endless waiting for triggers” are executed in the INIT or EXIT parts of tasks.
A indicator for such a cause can be seen in the logger of the PLC: normally, every transfer produces 2 logger entries: “start installation” and “installation finished” … if a entry “start installation” is there, but the “installation finished” is not yet there or this entry is generated later after a manual reboot, then you should check first your INIT / EXIT routines for situations where the code could “stuck”.

Best regards!


previous transfer finished as expected and PLC code worked as expected.

But this transfer ended with this error.

I reset the PLC and reinstalled the PLC, so I assume there is no way to find out why this happens.



ok, thanks for your feedback!
I agree, at the moment we can’t figure out more since it worked again after initial installation.

Best regards! Alex

Hi @WalterHof, because you can not reproduce issue anymore, I marked your workaround with init installation as a solution. Feel free to continue with this discussion later on if anything new come up.
PS: Please make sure that the latest AR is used.

AR version: E4.92. I assume this is the latest AR version (I hope so).


@WalterHof - I received this error too. I had two projects opened (two Automation Studio instances) accessing the same CPU. The problem disappeared and I could transfer my main project to the CPU when I closed both Automation Studio instances down and restarted the instance I was interested in.

1 Like

I only had one project open. I also shut down AS but this did not help.