exOS's Sample cannot run as planned

I have download the sample Watertank. But the program on the PPC3100 cannot run normally. The result is as follow. The function block always had the error -1040121343, which means the target is invalid.

But I didn’t change any config. And I checked the program and the IP config. The IP of enp0slf1 is Also I can PING Also, program’s config was right.

I also has installed the related connection package by setup_build_environment.sh.
So what should I do more to make the sample run normally.

Hi Zhihong, did you installed the exos-server? you need to execute the package “exos-server_2.1.0-1_amd64.deb” on your Linux target as sudo, you can find it in: TechnologyPackages/exosTechnology/2.1.0/Modules/Server/exos-server_2.1.0-1_amd64.deb
GUID: 5cb75760-d69e-4c23-8620-dc5f5cad0397

1 Like

Maybe have something wrong? Could you tell me how to fix it. TAT

Hello Zhihong Luo,
-1040121343 error usually means there is error in exos-server, neither installation or communication.
I take it that the PC you have is not the one prepared forehand with exos in mind, but just one with Linux installed. Usually Linux system in the pc have fs-protect activated.

In this case, you likely deactivated the fs-protect in the bios, wihout fs-protect, the hypervisor is not running in the Linux, and when installing the exos-server, likely ethernet port from AR and Linux in not found, and firewall must not have included the IP to allow communication between AR and Linux.
The best choice is likely to reinstall Linux and have everything running (hypervisor, exos server, etc) before enabling the fs-protect.
A second option would be first with fs-protect deactivated from bio, remove the installed server form Linux GUID: ac090e71-2b75-4465-b99a-9cec54fe4e23 following each step should delete the existing installed exos server.
now gain with fs-protect activated, install the exos server (the hypervisor should be running), and it should now include the IP for the communication, with this you should be able to test the sample, the problem with this is that each time you restart the PC, the exos-server must be reinstalled (because without fs-protect, each time the machine restart the memory is “resseted”)

Now, as the logger say, I have installed the exos-data instead exos-data-eth. I thought systems communicate each other through the IP, so I selected the wrong package before.

Now the sample has run normally.


Hi, we had a chat in parallel, and as you wrote, you worked your way through it :slight_smile:

I created a blogpost which covers some of the findings, ant things that are good to know when using, or starting to use exOS. exOS FAQ & Getting Started

What I didn’t cover, was the reason for the first probem here, that you should only install the exos-server.deb package on your target system, all other packages will be installed automatically, please also see the installation chapter in the help.

If you had installed exos-data.deb instead of the exos-data-eth, you wouldnt have seen the problem, because the dpkg would see that the package was already installed, but you can only have one of the packages installed on the target, because they are using the same resources, just that

  • exos-data is intended for hypervisor system with shared memory
  • exos-data-eth is intended for simulation and build targets (WSL) without shared memory support.
  • You can find some more info on that here exOS cross compiling

Again, the exos-data packages should not be installed manually on a deployment target.

Cheers, and keep up the good spirit!