OPC UA Server enable steps for X20CP1584

we have X20CP1584 and Beijer iT15BR HMI,

To enable the OPC UA server, first go to the Physical View:


Then right-click on the X20CP1584 and select “Configuration”:


Expand “OPC-UA System”, and then set “Activate OPC-UA System” to “on”:

You can find further details about the OPC UA settings in the Automation Studio Help here!


Thank You for the reply.
I have already checked in AS Help but it did not worked.

We need to add any libraries…?


After enabling the OpcUa server did you add the variable configuration file to enable the variables you want visible in OpcUa?

Please see Adding OpcUa Default View file and here How to enable variables in the help.

1 Like

Thank You for the reply.
I have already checked suggested steps, but it did not work.

Any other Steps or Configuration to be done…?

What are you using to check if the OpcUa server is working?

Common practice is to use a 3rd party OpcUa client like UaExpert. It gives you the ability to browse for the B&R OpcUa Server and check if you can read/write variables.

1 Like

I’m also using the UAExpert software to check the Server.

Now the B&R OpcUa server browsed and I’m facing problem where to browse the variable.

From were we can get to know the Node ID…?

Can i know the how the tags are browsed in UAExpert. Any configuration to made in program.

If you navigate to Objects > PLC > Modules > Default you should see your task names (HMI_Inputs in my case) which then contain the variables you have enabled for this task.


If I add the same NodeID manually it also not working for me since the NodeID doesn’t exist.

But it’s working for all other Nodes I have enabled for HMI_Inputs task / program.


As inform navigated, but we did not find any Tags in Module.

In Automation studio, we need to modify the any configuration…? As suggested before we have modified the configuration.


do you already have activated some OPC UA tags in the Automation Studio default view configuration?

As explanation: enabling the OPC UA server does not automatically expose every process variable for access through OPC UA - so you have to configure, which variables should be accessible (by what users, with what rights, and so on).

Please have a look here in the online help how to activate the process variables = OPC UA tags needed.

As a short example:

  • process variables that are not exposed by OPC UA (which are all by default) are shown “grayed out”
  • activated variables are shown in “blacked”, also the parent elements are marked by a red explanation sign (in the screenshot below, I made a pointer to those activated examples)
  • to activate a process variable, right-click it and use “Enable Tag”
  • be aware, that after activation the OPC UA tag has properties to setup if needed (for example the access rights - see 2.nd screenshot)
  • don’t forget: all changes get only active after build & transfer

Best regards!


I’m already Enabled the OPC UA Default tags.

we need to modify the any configuration…?


do you also have already set up the user role access rights?
You can do this at the root (“Default View” icon) and inherit settings to all of the childs, also you can set it up / change it for every node.
Please see here how to setup user role rights in OPC UA.

By the way, do you have a login for B&R homepage?

  • If not, you just can ask your B&R sales representative to get one.
  • If you already have a login, I recommend to download a very good training module about OPC UA available as PDF document in the download area (“Automation Academy → Training modules → POWERLINK, openSAFETY and OPC UA → TM980 - OPC UA basics and use”)

Best regards!

i’m have already set up the user role access.

we need to modify the any configuration…?


to be honest I’m not 100% sure, but if not done already I would recommend to set at least the visible and browse access for everyone at the root node (“Default View”), I could imagine that this is needed to browse the modules under PLC in UAExpert.

Unfortunately I’m not able right now to make a test, but maybe I’ll manage it later today.

Best regards!


Does “Anonymous” user exist in your user-role system? If you have deleted please add it again. It is compulsory for log in to OPC UA server with no user.


I also suggest to consider checking this post. Chapters “configuring OPC UA server” and “addition information” could be useful.

How to communicate two controllers thought OPC UA - Share Info & Ideas - B&R Community (br-automation.com)


Hi @sandeep.kodachi, do you have any further updates here? Were you able to confirm that the Anonymous user exists with role Everyone?