X20CPU 1685 Runtime not updating after adjusting on board mode CPU switch

Hi All;
I can not download the software to X20CPU1685 on the new machine. During runtime update its give me failed. I adjust plc switch on board, than i give the IP adress and subnet mask on project to plc. You can see details below. Also ı can downlod if i change to dip sw to CF mode there is no problem but on board mode not possible runtime update
Thank you…

My RunTime versions
AS Software details

Hello Murat Özcan

Without further information I suggest the following:

-Make sure that the switch is on right position pointing to ONBOARD and not any position in between CF and ONBOARD.

-Make sure that switch is done when the machine is powered off. Like not switching when the plc is powered.

-Tried using a newer version of Automation Studio and newer Runtime version, currently 4.12 is avaible

1 Like

I would just add one more test. Just power off and on PLC after download and check if PLC is visible in online browsing and what is state of it (IPaddress is set? AR version etc.)?

1 Like

I tried what you said but I didn’t get any results. Lastly, I wrote a CPU-only and empty PLC program on a CF card. Then, without removing the CF card, I was able to shut down the system, put it in OnBoard mode and load the empty program.
Then I was able to open my project and download the project to the plc. After that I remove the CF card than restart the system so there was no problem.
Thanks for your help.

1 Like