AcoposMulti Axis Init Issues

Hello,

We use ACP10 and have been seeing more and more issues with initialization timing with every new mapp update.

We have an issue we are trying to diagnose where we updated a program to the latest AR/mapp etc and now we are getting drive errors. The errors pop up as though accel parameters are set to 0. I also noticed that the mapp axis basic FB no longer comes has the Active output set to TRUE and the drives aren’t showing up as initialized.

If I do a warm restart, I only get the errors from the accel set to zero, but the FBs are running so I can clear errors and run. If we power cycle the machine, the FBs do not show active, etc.

What would cause the mapp axis basic FB to not show active?

I have the mapp axis config enabled for all of the axis and if I create an axis init table for an axis, it will load properly.

I have the Acp10cfg.ncc file set to default parameters in regards to Network initialization and have tried various changes to the Execute at NC software initialization and Execute automatically after ACOPOS reset with no positive change.

Original:
AS4.7
mapp 5.18
AR F4.37

Updated:
AS 4.11
mapp 5.24
AR F4.92

Hello,

i assume that your acceleration is not 0 in your configuration, this comes not clearly out of your explanation. Acceleration 0 is not allowed and thats why in such a case an error would be thrown.

Normaly changing Versions should not be a problem. But in your case it seams that there is some problem occuring.

What i would suggest, by currently not knowing the real issue:

  1. a. Delete the Temp-Folder of the Project while the AS is closed


    b. Rebuild the Projekt and check again

  2. If this doesn’t help Delete the mapp Configuration Files in the ConfigView and recreate them from the Toolbox.

  3. If there are still issues load a Network-Command Trace and post it here.

image

Greetings
Michael

Through a day of testing with I was able to get a configuration that works. We use mapp axis basic configs, but I still had to define an identical axis init table for two of the drives.

I was able to get some success after downgrading the APC3100 firmware from 2.2.7 to 2.2.6 and setting the two parameters in the .ncc file.

Execute at NC software initialization: No
Execute automatically after ACOPOS reset: No

AR E4.92 / Mapp 5.21: Worked (2 consecutive power cycles)
AR F4.92 / Mapp 5.24: Did not work
AR F4.92 / Mapp 5.21: Did not work
AR E4.92 / Mapp 5.21: Still worked
AR E4.92 / Mapp 5.24: Did not work

Other notes:

  • Program has 22 axis defined, 18 are populated on this machine.
  • I have an almost identical machine running E4.92, mapp 5.21, and the .ncc parameters set to yes.
  • When setting the final AR/Mapp versions I still had issues after the first power cycle. After about 10 minutes, I power cycled again and the machine came up with just two mpaxis FBs not showing active. I defined an axis init table that matched the mapp axis config files and then the machine came up with just one error showing the acceleration on the power supply was set to zero. That issue was able to be cleared so I could get the machine up and running.

There appears to be a timing issue when you have a lot of drives and especially when you have some defined that are not being used in the active machine.

Do you use MpAlarmX in that project?

Can you try to enable the MpAlarmXCore instance with a delay of a few seconds after startup of the plc?

image

We also had such behavior in the past and that was the solution.

1 Like