Arsim fails to boot

I have a brand new install of Automation Studio 4.12.4.107 with a commercial site license on a Windows 10 machine. I have made multiple attempts to create a simple project but can never get to the point where I can simulate. The Arsim Startup dialog simply says:

“BR Automation Runtime B4.93 booting…”

and never changes. After two hours it times out. I’m looking for any information on how to correct this problem.

Here are some things I like to try when I run into ARSim issues:

  1. Make sure that you only have one Automation Studio project open. If you have multiple simulation projects open at the same time, multiple instances of ARSim can start and this doesn’t always work out well.

  2. End the ar000.exe task either through task manager, or by right clicking on the traffic light in the Windows task bar and clicking “Exit ARsim”.

  3. Open the project directory in Windows Explorer and delete the Binaries and Temp folders. This will delete the simulation directory as well as the compiled binaries for the project. I’ve found that Shift+Delete (permanent deletion that bypasses the Recycle Bin) is a little faster here. Just make sure only these folders are selected or else you’ll delete project files!

  4. In Automation Studio, do a full project rebuild (Project → Rebuild Configuration).

  5. Make sure that simulation is active (either use an Automation Studio configuration that has a Standard PC target or click the traffic light icon to activate simulation).

  6. Click Project → Project Installation → Offline Installation and then make sure Create ARSim Package is selected. This will rebuild the simulation folder and can be a helpful alternative to an online transfer when you’re not able to connect to the simulation.

  7. Start the PVI Manager from your Windows Start menu in the B&R Automation folder. If you’re using AS 4.12, you can start PVI Manager 4.12. PVI is the communication protocol that Automation Studio uses to communicate with targets. The PVI Manager program facilitates this communication. If this program isn’t running, your simulation may be running but unreachable by Automation Studio.

  8. Wait for the simulation to finish booting and check the dialog window (right-click on the traffic light icon in the Windows Taskbar → ToggleView).

At this point if you’re still not getting anywhere, there may be a problem in your project that’s preventing the simulation from starting correctly. Here are a few other things to try:

  1. If the PVI Manager is running (you’ll see an icon in your Windows Taskbar), and you’ve restarted it recently, you may have online communication through Automation Studio. Ideally, you’ll want to see that the target is in RUN mode (in the lower-right of Automation Studio). If it’s not in RUN, it may be in another mode (e.g. DIAG for Diagnostic mode). If you’re connected, you can check the Logger to see what the problem may be.

  2. Try creating a new, completely blank project and just transfer it. A blank project with only a target should start in simulation just fine. If you’re able to get a blank project working but not your other project, there’s probably something wrong in the other project. This will rule out installation or IT related issues.

1 Like

I’ve tried your items 1 through 7 multiple times with no luck. Essentially, step 8 never happens. The runtime never finishes booting, so the target never enters RUN mode and nothing can be transferred.

I tried creating a brand new project with a Standard PC target and saw the same result.

Simulation is supposed to be available with plain vanilla Automation Studio, right? It doesn’t require a separate license or anything?

Are there any notable messages in the console?
The newest messages are located at the bottom.
2023-12-19_15.26.08

Create empty project only with hw or simulation PC without any tasks Make sure that you have started your AS as admin. Try different version of AR.

Nope. Nothing in the console.

I’m an admin on the machine. I’ve created an empty project using the StandardPC hardware, with AR B4.93, G4.93 and H4.93. Same result every time:
image
AR never finishes booting, and target remains OFFLINE and never enters RUN state.

To answer your earlier question, simulation is already included in Automation Studio. It will time out every 2 hours and you’ll have to restart it. There is a license you can get which removes this timeout, but that is the only thing you’d need a license for.

Do you have any antivirus software on your computer? It’s possible that it could be blocking the program. If you’re able to temporarily disable it that would be a good test.

Additionally, ARSim needs TCP port 11169 to function. Can you check that port 11169 isn’t blocked on your PC?

The netstat tool shows nothing listening on port 11169 and periodic output like this:
TCP 127.0.0.1:52444 MK0AL92H:11169 SYN_SENT
[PviMan.exe]

So, the PVI Manager is attempting to connect, but nothing appears to be listening.

What process should be listening on that port? I see AR000.exe, AR000Debug.exe and ar000loader.exe all running in the Task Manager.

As for anti-virus or firewall stuff, I can write my own server (python, Java, whatever) and listen on port 11169 with no problem. It is definitely the runtime not starting and/or listening.

You will want to look at the AR000.exe for port bindings.

  1. Open the Task Manager (right-click Start menu > Task Manager).

  2. Go to the Details tab.

  3. Find AR000.exe, and look for the number under the PID (Process ID) column.
    In the example below, this is 23172.
    image

  4. Open an Administrator level command window/terminal in Windows.
    (Type ‘command prompt’ into the Windows search bar, right-click the Command Prompt object > Run As Administrator)

  5. Type the following: netstat -ano | find “PID_OF_AR000”
    Replace PID_OF_AR000 with the PID number found earlier. For example, netstat -ano | find “23172”
    image

You will find the list of connected addresses/ports related to AR000.

You can also reverse the procedure by searching for a particular port number (ex. 11169 or 5900) with the | find “xxxx” filter, and look up the PID in the Task Manager to find the process binding that address/port.

AR000.exe is showing zero connected addresses or ports:

image

Hi,

this looks really quite strange, I’ve never seen such a behavior on my systems.

Can you please have look into the folder of your simulation (where the ar000loader.exe file is located, normally under the \temp\Simulation<name of configuration><name of cpu>\ )
→ There should be a “AR000log.txt” file - can you please post the content of this file?

It’s not much inside this file, and if there’s a entry “No ARsim registration found!”, that’s ok and has nothing to do with root cause of your issue.
More or less, the content should look like the following picture, are there any other entries on your system?

My log file is essentially identical to yours:

Thanks, it looks like that at least the OS kernel seems to boot.

I’ve no idea what happens, but it’s very unusual that the ArSim has no binding to the local loopback address at all - setting up bindings for the online protocol (port 11169) to 127.0.0.1 is the default setting, even if nothing is changed inside the PLC configuration.

The only thing I would suggest for one more test is to change the IP address inside the ArSim’s ethernet configuration from “172.0.0.1” to “the real ip address of your machine” (like it’s described here under " Connecting via physical interface on the PC"), then do a offline installation from Automation Studio, and check with “netstat” if behavior has changed…
… to be honest, I never heard from any problems with binding of sockets to the local loopback IP address, but I’ve no more idea that was not written here before.

Of course I’m sure that the following information is clear and has nothing to do with the behavior above.
But in addition I’m writing down the information here for possible future visitors of this thread:

Automation Runtime only supports IPv4 (by now), so usage of Automation Runtime, including ArSim, in a “IPv6 only” environment possibly may not work as expected.

So, in an attempt to eliminate any possibility of our corporate network somehow causing a problem, I created a Hyper-V virtual machine with a brand new installation of Windows 10. After installing and activating Automation Studio, I created an empty project with the Standard PC target and…
image
It worked.

Time to go find out what ridiculous thing our IT group has done that could cause this.

When you figure it out, let us know! I’m sure this post will be helpful information for someone else.

Hi Jim,

thanks for reply.
If you find out the root cause, I would really appreciate if you can post it here, many thanks in advance!

Best regards,
Alex

OK. It looks like the root cause was Windows Defender Firewall. I haven’t absolutely verified this, but I’m confident. On the new VM, when ar000.exe starts, Defender pops up a dialog to allow ar000.exe to open ports. On all other machines I’ve tried, the dialog never appears. I’ve seen this dialog pop up in many videos I watched while troubleshooting this problem, but I always assumed that I didn’t see it because the firewall is listed as off for all networks:

But, apparently sometimes OFF isn’t really off. I’ll have IT check into it and if that doesn’t fix things, I’ll report back. Otherwise, I would consider this solved.

3 Likes

Hello @jsculley

As we havn’t heard back from you since over a month, we assume that the topic is solved
and you previously posted information was the solution. I’ll mark it therefore. If there is anything else, let us know.
Thanks. :slight_smile: