Automation Studio configuration import FDT/DTM error

Hi all!
I have an issue when copying an entire configuration from a project to another in AS

Configuration is copied correctly and I am able to rename it, but when it gets to the build an error message appears: “The supplied DTM was not found in the supplied FDT project”:

The other project where the configuration is copied from is working fine and builds without errors.

I tried to search in the Help and no results are found, and in AS the message is not cross referencing anywhere.

Am I missing something? Thank you!

Hello Giulio,

Welcome to the Community!

The first question to get out of the way is, are you using the latest B&R DTM version on the PC(s)? If you are transferring between different PCs, you will want to use equivalent and latest versions on both. The latest version of the DTM is v1.6.7.4. If your DTM version is out of date, then it’s a good opportunity to upgrade to the latest and retry your copy + paste.

Link to latest B&R DTM version.

To upgrade your B&R DTM version:

  1. Close all versions of Automation Studio.
  2. Open Settings (gear) > Apps.
    Or the location in your Windows where applications can be uninstalled.
  3. Search or find for the “B+R DTM.”
  4. Click on it to expand the options. This is also where you can see the installed version.
  5. Click ‘Uninstall.’
  6. Follow the prompts to uninstall the DTM.
  7. Download the latest B&R DTM version from the B&R website, link.
  8. Execute the downloaded installer.
  9. Follow the instructions in the installer.


Hello Austin,
thanks for the reply.

I updated the DTM version to the latest available, problem has not been solved.

The project from where I’m copying the configuration has been made and built on my PC, and the same for the other project where I’m trying to import the configuration.

Seems that in the copying process something has not been fully copied, or maybe some DTM references have not been imported correctly… I already had issues in the past with external devices not transferring correctly between projects.

I didn’t had this error, but maybe you could compare the DTM Folder in the configuration View. At least the amount of Files should be the same between your two projects.


1 Like

Hello Micheal,
thanks for the input.
You were right, seems that some “Additional files” in the DTM folder were not copied:

Copying them manually (without adding them in the .pkg files, so they should not be considered by AS) solved the issue and project now compiles.

Thank you!

1 Like