B&R AS4.12 on Windows 11

hello,
i am trying to install AS4.12 on windows 11 and the installation fails on the system requirements step due to .NET framework 3.5 not installed, i have tried to install the .net 3.5 in any possible way (feature, external file, BIMS, disabling firewall) but it fails every time. did anyone else encounter this problem? how was it solved? is there a way to bypass the .NET requirement?
thank you.

How do I activate .NET 3.5 SP1?
Hello Ron,

Activate . NET Framework 3.5 in the Control Panel
Press the Windows key. on the keyboard, type “Windows Features” and press Enter. The Turn Windows features on or off dialog box appears.
Check the box. NET Framework 3.5 (includes .

B1

hi,
as i mentioned i already tried this and i get the following error:


thanks.

Hi,

it looks a bit like that there’s a general problem with Windows Update services on your system.

  • are there other pending / stuck / failed updates shown in Windows Update?
  • could you try to run the Microsoft .NET Framework Repair Tool?
  • are there any errors / abnormalities inside the Windows Event Logs?

hi,

  1. yes i experience some issues with the windows update, it will fail and then i select online download and it will continue.
  2. i tried and it did not help.
  3. i found the log in the BIMS when trying to install from there. it shows the same error.

Hi,
I am afraid there is not much we can do.
There is a Microsoft online help regarding the failure code:

Hi Ron

We encountered the same problem with Win11 and also had issues with the Windows Update.

The following workaround worked for us:

  • Download .NET 3.5 Framework for Windows 11
    .NET Framework from Windows
  • extract the files from into C:\drv\sxs
  • run command with command line tool “Dism /online /enable-feature /featurename:NetFX3 /All /Source:C:\drv\sxs /LimitAccess” as admin

Maybe this will solve the problem for you as well.

Cheers Patrick

hi patrick,
the file is non extractable (.exe) so when you say “extract the file from…” what do you mean?
thanks

Even though it is an exe file, it is extractable. I don’t know if it is possible with standard Windows tools, but e.g. 7-Zip can extract the file.

Hi Ron

Sorry, this is my mistake.
The link I provided, is for downloading the installer of the .NET 3.5 Framwork.
So you can try installing it this way.

The command line command is related to the "Deployment Image Servicing and Management (DISM) functionality of Windows if the installation is not possible with the installer.

https://learn.microsoft.com/en-us/windows-hardware/manufacture/desktop/deploy-net-framework-35-by-using-deployment-image-servicing-and-management–dism?view=windows-11

There are two possible ways to install the framework on your computer. One with and one without internet connectivity. (See link above)

Check out the link and try it that way.

Good luck