Eth 1 apc3100 freeze

Hi,
We are using an APC3100 pc from B&R wich has 2 ethernet ports, ETH1 and ETH2.
We reserved the ETH1 for the Automation Runtime and ETH2 port for the GPOS (Debian).
We are also using the B&R Hypervisor to communicate beetween the 2 OS.
Both ports are connected to our office LAN, and there is a gateway beetween (a “Ewon Flexy 205”).
We observed that sometimes after a project download or after a warm restart (via Automation Studio button or via the B&R library function) we cannot longer communicate with the ETH1 port (but we can communicate successfully with the ETH 2 port, reserved to the GPOS).
The only way to communicate again with the ETH 1 port is to restart the power of the APC3100.
We tried using the SYSreset() function to “revive” the connection but it doesnt work.
We also tried using the brhypsrvSystemReboot() function that can be found in the …\BRHypervisor\ISCDevelopment.… folder created with the offline usb installation, but the function returns a Segmentation Fault error (but this was an experiment, maybe we are not supposed to use this).
We tried upgrading the Automation Runtime to the latest version.
We cannot find a “software only” solution to this problem.
We think that the problem is not related to the gateway or the the switches (or any network hardware) we use.
Has anyone ever encountered a similar problem?
Could this be a problem related with the kernel under the AR OS?
Thanks in advance.

Hi,

haven’t seen this until now, but I’ve some questions about the behavior to get a better impression if we have to look more in hardware or in software direction.

  • Can you please share the logger of your system? Anything “unusual” inside?
  • Do you use own code to change settings of the ETH1 port inside your project (for example AsArCfg() functions), or is it a fixed / static IP set by the project, or is it a DHCP client?
  • About the ETH1 port:
    • have you tried to ping the IP address of this port? Is there a ping response?
    • can you try to ping from GPOS the Hypervisor internal “virtual network” IP address (per default it’s 192.168.137.1)? Does this one response?
    • how is the LED state of ETH1 if the issue occurs? Does the LED’s signal a physical link, or are they both off?
    • I think, the gateways integrated switch is managed. So, is there any additional information available inside the gateway regarding “port state”, “port errors”, and so on? Anything “unusual” inside there?

Best regards!

Hi, thanks for the response.
I replicated the problem again after a warm restart via automation studio (with the network configuration described).
About your questions:

  • For the logger, the only thing related probabily to this situation are these warnings:

    I can’t find anything else unusual.
  • For the ETH1 port we set a static IP address by the project, but we also give the possibility to change the IP with the B&R function CfgSetIPAddr (and the other AsArCfg functions for subnet and gateway).
  • We cannot ping the IP address of the ETH1 port (host not reachable messagge).
  • The internal communication from GPOS works fine, we can in fact reach 192.168.137.1.
  • This is the led situation on the APC3100 (they look like are both working fine):
    .
  • From the gateway we cannot find any useful information, but we observed that this problem occured also without this device in beetween.
    The only way to restore the connection is by restarting the power.
    We can’t identify the possible cause.
1 Like

Do you use latest AR and the latest hypervisor driver?

Yes. We tried also updating runtime to the I4.93 version, and reinstalling the hypervisor drivers with the actual version. It did not fix the problem.

1 Like

Hi,

since the internal interface is working, could you please check from GPOS side the SDM “Ethernet Network Devices” area if there’s also the setup shown as expected?

Best regards!

Here are some screenshots:
image
image
It’s the same in both case (with port ETH1 working and not)

if the problem is reproducible with the latest AR and hypervisor driver, then it is something developers have to take a look. So I would suggest to contact your local B&R office support and refer to this community. As a last step I would try to reproduce issue without tasks, if problem is not reproducible then enable them task by task. Maybe you will find some relation to user application.

2 Likes

Hi,

Just out of interest:
what message do you get as ping response?
Is it “destination host unreachable”, or “reply from IP_ADDRESS: destination host unreachable”?

I’m asking because I expected a ping response “response timeout” if there’s a direct connection and both systems are in the same IP network.
So is it a routed IP connection to ETH1?

Best regards!