License code

Hello
I installed Automation studio 4.10 when I open software have expired license error I get activate license from B&R by email when I want activate I face this error
The request was aborted could not create SSL/TLS Secure channel
Please help me how I can solve it
Thanks

Hello Isabella,

I tried right now the relicensing of my Automation Studio 4.10 installation, and it worked as expected, so it seems that the B&R licence server is up and running.

Therefore, unfortunately I’ve no idea why it fails with your installation and only can recommend to contact your local B&R office for support.
If it’s a general issue with the IT infrastructure, for example that our licence server is not reachable out of your network or access is prohibited by IT security measures, you can try an offline licensing by sending a licence request file + additional data to your local B&R office.
How to do this is described here in the Online Help.

This will be related to the recent Cyber Security Notice.

B&R products use insufficient communication encryption (br-automation.com)

The licensing of AS V4.10 is based on the Technology Guarding Tool. In the Cyber Security Notice it is mentioned that a TG Tool Version >= 1.4.0 is required now and older versions do not work anymore. I guess the Version included in the AS V4.10 installer is lower.

You can download and install the newest version of the TG tool separately. After installing the new TG version, it should work again.

Technology Guarding | B&R Industrial Automation (br-automation.com)

PS:
This should work for all AS installations >= AS V4.2.x.
AS Versions <= 4.1.x do not yet use the Technology Guarding tool as far as I know. Please contact your local sales or support team in such cases.

3 Likes

It probably works for you, because you already have a newer Technology Guarding Tool version installed on your system from another AS installation.

1 Like

I already installed it and it worked for 90 days, but now it won’t activate again

Hi,

could you try Patricks suggestion with updating the Technology Guarding Software package?
Because the change on the licence server was done at 1st of march, that could explain why it still worked 90 days ago, but now it doesn’t work anymore.

Best regards!

you got the solution? I’m also facing the same problem can u please give me solution if u have ?

After the changes made on the 1st of March the license server requires now TLS 1.2 to be used to securely connect to the server. The new versions of Technology Guarding package support TLS 1.2, but Windows programs based on .NET framework version less than 4.6 by default still try to use the less secure connection than TLS 1.2. To fix it it’s necessary to force them to use TLS 1.2 by setting one registry value in Windows’s Registry Editor. The fix is described HERE

2 Likes