mappView - Unable to Login with login widget using created users

Good morning to everyone:

I followed the instructions of the B&R Help explorer “mapp UserX: User management with the user role system” section; but when I load the project on the web browser and I try to Login with the users I´ve created, the Login widget returns “Authorisation failed” message.

Does anyone know what could be happening?

I share different images about the configuration for a better understanding.



On the first view I do not see any problem. Are you sure that you have used proper credentials? what is AS studio logger saying? can you share with us printscreen from it? Have you tried your credentials with RBAC (instead of MpAlarmX)? What version of MV do you have? :slight_smile:

Hello Jaroslav, here you have the prinscreen you asked for.

Anyway I´ve just tried my credentials with RBAC and it seems to be working :sweat_smile:

Do you know why I sould choose RBAC option instead of MpAlarmX?

Now I´ll try if once the login is succesfull it redirects me to the Home page.

Thank you very much Jarsolav!

If you need only authentication to mappView client based on roles (so to front end only) then RBAC option is the right one. If you need to connect mappView with MpUserX (frontend and backend) then option MpUserX is the right one. Then you have possiblity to use local role system or from active directory, more details B&R Online Help.

Can you try again, but with no password defined for the Anonymous user?

From the AS Help: mapp UserX General Conditions

If mapp UserX is used in combination with mapp View, it is important to note that a password is not permitted to be defined for user “Anonymous”. User “Anonymous” is active as soon as a user logs out. A login is not required for “Anonymous”.

Sure, I´ve just tried and it changes the user too. Nice to know that.

A post was split to a new topic: Mapp View Start Page question

Nice! Did this change improve the behavior, or are you still unable to login when the Authentication Mode is set to MpUserX?

I had the same probelm, it was caused by me, copying a user with password and renaming the user.

As i had a look at the User.user file via a texteditor I found out, that the pasword hash under <Property ID=“Password” Value=
was of cause identical.

due to the kind of encryption of the user-paswords by the Automation Studio this causes a identical problem as described by the thread opener.

I could solve this by retyping the pasword in the user configuration at the AutomationStudio.

Hope this will help someone.