Opening 2nd mappView Session Resets Values To Zero

I have a mappView v5.12.1 running on an X20CP3585 AR B4.82 and have had this issue since commissioning. Its been running for over 4 years now and I have just dealt with it.

I have one mappView session running locally at the machine on a 6PPT50.121E.10A HMI.

If I navigate to the mappView using a browser on my PC, a speed setpoint will reset to zero for both my session and the local session. Essentially, opening my session writes a zero to the PLC and it is then reflected on both sessions.

During commissioning, I tried using the Read/Write binding and tried binding to the tag’s .value, but it still did the same thing.

Is this typical behavior?

I have the value binding configured like this:

Hello Seth,
I hadn’t actually heard of this problem before so I had to test it out.

I added a simple NumericInput widget bound to a global variable just like you show in your example. Initially I didn’t change the Binding Mode and the variable and widget behaves as expected with 2 visualization sessions open.

No matter how I change the value of that variable both sessions and the PLC watch reflect that new value. Reloading / starting a new session doesn’t change the values.

Now I noticed that in your screenshot you have Binding Mode set to Init Read / Write so I tried that.

The result was very strange behavior and I would say almost exactly like you described it.
Every time the mappView visualization would start that variable I have bound to the NumericInput would get reset to ZERO, on the PLC and the other session.

You said you tried the Read / Write Binding Mode and didn’t see the behavior change. Can you please make sure that the actual binding also changes. It should show mode=“twoWay” The Init Read / Write would show as oneWayToSource


I hope this helps if not please let us know.

1 Like