Server's certificate is not trusted

Hi all.

I made an HTTPS certificate and configured the mappView server to work with it.

When i try to access the mappViewServer with a B&R T50 panel, i get this message

After clicking “OK”, i can continue to the mappView server but i get it again on every establishment of connection between PLC and Panel.

Question: How can i make the panel, recognize this connection and not asking every time to override the security check?

I think you would need to import and install your certificate to browser. Certificates can be imported to the T50 panel by setting up network sharing for internal user memory “usershare”, creating a directory called “cert” in the internal user memory, and copying the user-defined certificates (with permissible file extensions for certificates: “.cer” or “.crt”) into the directory “cert”. Each time the browser is started, all certificates are imported from the directory “cert”. B&R Online Help

1 Like

Can you explain me more about the procedure on how to configure “usershare”?


the configuration of the usershare can be done in the configuration pages of the T50, please see here in the online help.

Best regards.

1 Like

Good morning.

I managed to connect to the HMI, using CIFS protocol and created the “cert” folder.

Now i get this kind of message from the HMI:

I investigated and concluded the following:

The certificate displays as not trusted because the certificate authority(CA) that generates the certificates is not on the “Trusted Root Certification Authorities” of the web browser that is used on T50.

The certificate was generated from Automation Studio.


  1. Is my assumption correct or i miss something?
  2. How can i make the certificate trusted?

There is an option on the HMI to “Ignore server certificate errors” but i want to avoid using it.

Thanks in regard.

“Server’s certificate is not yed valid.” is most likely caused by the PLC time not being correct.

So you most likely have generated the certificate to be valid from XX.XX.2024, but the PLC clock might be something in XX.XX.2000, which is why the certificate is not yet valid.

When using certificates it is important that all clocks in the system are correct.


Changed the screen time-date by connecting with OPC-UA.

Noticed the following things:

  1. The date is always reset to “2020-16-12” after turning off and on the panel.
  2. After setting the correct date, both on the PLC and the panel, the panel displays a message stating “Server’s certificate is invalid”.

The certificate i uploaded to “cert” folder is in “.cer” format, an exact copy of the one that i have on the “OwnedCertificates” folder of Automation Studio.

The version of T50 is 1.5.0

Any update on this?

Thanks in regard

can you try your certificate locally in the browser on your PC. It looks like that certificate itself has some issue, maybe wrong parameter etc?

Hi, I created this article for testing your certificate with local pc. How to configure a secure connection between mappView server and mappView client. Test with T50 I will do next week if you do not solve it. Have a nice weekend.


Hi again.

Thanks for the guide.

I managed to find a solution for these kind of problems but in order to share, i need to attach a .zip file and i am not allowed using this editor.

Maybe can you send me a private email?

Hi @c559098 - you will be able to add attachments (10MB or less) once you reach Trust Level 1.

1 Like