4C2000 Panelware Controller & PG2000

1.) How to change processor type in PG2000 for offline project? From the PCCSW configuration this is not possible.
2.) In documentation I found bootcomm to load OS to panelware. In PG2000/SYSTEM there should be OS files, but I can’t find them. Not there not anywhere else…

Anybody there still remembers old PLCs and PG2000?

I think the problem might be related to not matching OS versions.
It seems the project uses 1.91 and the CP200 runs 2.5
I can give you 1.91 and the bootcom exe but to be honest thats all I can help with. My experience with PG2000 is more or less not existing as this topic is almost 25 years ago (if not longer)
cp200.zip (207,7 KB)
Attached V1.91 and Bootcomm

Thank you Oliver! Just a question if you remember… Should the key switch be on position 0 or 7 to perform a OS download? The documentation is not quite exact on that…

Sorry I do not remember this one but as this are only two options I would simply test both

I remember something like since OS 2.2x an OS update can be performed in every mode, but since this is an older version, it needs to be in BOOT mode

In any switch position (0, 6, 7, even 5) using “bootcomm.exe” I can establish communication, but download is not done…


I had a look into the old manual, think the operating mode on a C200 has to be 6 (System download).

I don’t know the bootcomm.exe, but the parameter -b57600 sounds like a serial baudrate?
Could you try to use a slower baudrate? Maybe 19200 or even 9600?
I don’t think it changes anything to be honest, but it’s worth a try to see if the error or the download percentage changes.

@alexander.hefner is correct. According to the old manual the OS download must be done in mode 6:

Thank you and @alexander.hefner! Yes, I have tried with mode 6. Also I have changed speed from default 57600 down to 9600. I have also used some options of bootcomm, like time delays, etc… I have tried many combinations, after each I performed reset (otherwise next try is not possible)… Maybe the RS232 cable isn’t OK. In documents I found three versions of it. I made null modem cable with shorting 4-6, but 7-8 I have (cross)connected. This is first one of cable specifications. The other has both 4-6 and 7-8 shorted.

Maybe my cable works well for PG2000 and basic bootcomm connection but not for the OS download… Good old DOS days… :upside_down_face:

As your download fails at 0% I think this could have basically 2 reasons:

  1. the cable and as far as I remember this cable should be a “zero modem cable”
  2. the RS232 of your PC is no real RS232 (USB adapter ?)

Oliver, may I ask you also for CP15x OS, if you have it by chance? Because the original application for the machine is made for CP15x. I don’t know if this could work on 4C2000.01 CPU, but I would like to try.

In the meanwhile, I have checked old B&R tickets opened in our company. We had exactly same problem in 2016 for the same costumer and same machine application and it was solved somehow. And on those tickets I noticed your name… Only difference is that time it was 4C2200 CPU. Unfortunatelly from tickets I can’t find a solution. Also PC which was used that time is not alive anymore. And the programmer (Darko) is not in our company anymore. I spoke to him but he also does not remember anything…

This will not work - you cannot download an OS which is for a different PLC.
Furthermore 1.91 does not exist for a CP15x and therefor I cannot give you this OS

Any chance that you have a ticket number or any other reference for me of the old problem ? I could then take a look at this. Tbh I do not remember that I answered 2016 to such a problem

I have real RS232 port and DOS 7.1 on my notebook. It is old and is used solely for problems like this. My cable is zero (or null) modem. It means it is connected Tx-Rx(2-3), Rx-Tx(3-2), SGnd(5-5). But there can be also cross connected CTS-RTS (4-6) and DTR-DTS (7-8) or if they are not connected it should be made a short-circuit between them on the DB9 connector. Everything seems to be like it should be… But it is not

Our ex-programmer told me to search his old tickets. I found two which may be related to this problem:

Not really in my opinion. Different PLCs and different OS versions
I am sorry but I am running out of ideas

Thank you Oliver. One more and last question… Does exist any converter to convert Panelware application to AS project files? Old application I can open, if there is no other chance, we will try to renew that machine with new PLC.

There is no converter but there is a porting guide provided with old AS versions (most likely As2.0) as far as I remember

Hello Oliver, I can’t give up… Maybe 8 years ago they’ve created new application based on original, with correct config file for C200 and they copied rest of tasks from original… I would do that but I had corrupted PG2000 installation so I could not see any of CPUs… Now I have got correct PG2000 from costumer archives and I know how to overcome this, only problem is that my CPU is now without system files and bootmanager doesn’t want to download the OS…

If you maybe have OS for C200 V2.2 revision 1.0, I could try restore system flash with it.

Here you go:
C200_V22.zip (194,1 KB)

Thank you!

I am really sorry to bother you so much… This is really my last request. Costumer found another C2000 to which it seems it is possible to connect. This one has version 2.5 on it. Is this possible? May I ask you also for OS for that version, just in case?
I will try first to upload the sysconfig and change parameters according to original project and dowload it back to CPU. If this will not work and OS is needed i will use original sysconfig and change the OS to V2.5 if you can provide it…

And we will reconstruct this machine with new B&R, just want to save the costumers production for that time. It is one of the biggest companies in our country so it is worth…