AS Help Issue

Hi Everyone,

I have a problem with the AS help.

I don’t know why but when i try to search a selected object with F1 button

, the helper don’t show me his specs but it show me the message that you can see in the screenshot.

Any suggestions?

Best Regards


The Automation Studio will not open a correct help for all Situations you can Press F1.

For example if i mark G04 in an CNC-Programm

I get the Help of the CNC-Editor but not the Help of G04-Statement

My suggesstion would be to write your search Keywords to the Search in Help, in my Example this will lead to much better results than the F1-Key.

Summary: For some Situations F1 works good for some it works not good (only opening Help window, which is at least were you can then search on your own).

  • If you descripe us your Position were you Pressed F1 and what was marked, we can check if we will get the same result. In addition we may help you with the correct info from the Help, as soon we know what you are searching for.


1 Like

Here the exaple, in this case I selected the cpu station.

so, if i press F1 help don’t show me the specs of the object.


I tryied to uninstall and reinstall AS Help but I’ve the same issue again.


In other case I would follow your suggestion and i type key-words on the search bar.

Thank you for your answer.

In this case it should work. So page in AS help with documentation of CPU should be opened. Do you have older version of AS installed? Does it work with older one?

1 Like

I made a fresh upgrade (reinstall) from AS4.12.5 to AS4.12.6

In both Versions it worked for me in this use Case (F1 on selected PLC in System Designer). Here is the upcoming Page GUID: e1ed6868-a63f-4b2f-a8ad-a21234346e6d

It looks realy as an issue on your System.
I would still suggest to use manual Search.

If you need a fix i think you should involve local B&R Support. There will be a deeper analysis of you system needed i think. The start of the analysis is to get more Data of behaviour, as Jaroslav suggested.



Hi Michael,

I Fix it! I opened AS like Administrator and the issue disapper!

Thank You for your support.

At next time! :handshake:

1 Like

The issue is present in older version too.

But i fix it! I opened it like Administrator

Thank you for your time!

1 Like

Thanks for sharing the solution with us. :slight_smile: I think i have to make a posted on my wall with “PC specific → Ask User-Rights” i think we will get such topics more often in days where not everyone will get admin rights as in past days.

Can you mark your post as a solution, so the Topic gets marked as solved.