Automation Studio ARSim stops working

I have Automation Studio with 4PPC50.121E-13A panel project,
Hardware module 4PPC50.121E-13A -
mappservices 5.15.1
mappview - 5.24.1 ,
PPC5x - F4.73 .

Last time I’m experiencing problems with ARsim: whole application stops working and there is no possibility to connect, untill I restart Automation Studio.

Does this happen immediately or after some time?

ARsim works for 2 hours until it stops itself when used without a ARsim license.

Just restarting the ARsim is enough, no need to restart the whole Automation Studio.

1 Like

just to complete information from Tommi, here is the link to AS help about ArSim license B&R Online Help

Thank you Tommi!
It happens literaly after few actions (clicks), much before 2 hours limit is expired. The project worked fine two weeks ago, but something went wrong last time . The real device (panel) shows no problems, no wdt/service mode issues are detected. Can it be size of project issue? It got bigger last time.

I’ve never heard of an issue like this happening due to the size of the project; it will naturally get bigger as you add programs, mappView pages, etc. Sometimes there are issues with the project build if the project path is too long, but since it sounds like the project is building okay that doesn’t seem likely either.

There is a Community post from a while back that has some troubleshooting steps for ARSim. You may find these useful. Here are some things I would look at if I was in your situation:

  1. Does this happen with any project, or just one project in particular? If you create a blank project right now, can you build it and successfully run ARSim?
  2. You mentioned that your project is working successfully on real hardware. Do you have multiple Configurations in your project for simulation vs. real hardware? If so, can you try running the “hardware” Configuration in simulation to verify this isn’t an issue localized to a particular Configuration?
  3. What is the output of the Console window (second tab in your screenshot)?
  4. If ARSim ever successfully started, it should have created log files that can be opened with the Logger. These files will be at [PROJECT_PATH]\Temp\Simulation[CONFIG_NAME]\[CPU_NAME]\RPSHD\SYSROM. In particular, the “” file will contain system log entries. Can you try opening this file using the Automation Studio Logger (if it exists) and check if there are any critical errors before the shutdown?

Then I would say disable all application tasks. Check that ARsim behaves properly and then enable task one by one. Very likely there is one which causes this issue.

Thank you Jaroslav! Thank you Marcus!
The problem was in one section that caused massive index out of bound exception, that lead to slow down the section. ARSim was stopped because of this issue, but WDT time was long enough to not produce same problem on real hardware.

happy to hear it. Please mark this question as a solved then :slight_smile: