Brake settings Virtual Axis compared to P3


I’ve got a question about the brake controlled by Virtual Axis compared to a P3.
I’ve got the brake working from the virtual axis, with simple settings as activation and release delay.

For the P3 i hoped to do it in the same way, like

but i’m getting an error message in cockpit “The settings of the axis are invallid”.

I’m using in both cases the same motor with brake, but where trying to make a cheap and slower solution with frequency drives and a quicker, more accurate and expensiver solution with the P3 but with the same induction motors.
I’m trying to get the configuration as much as possible equal.

I tried to get it work with some gambled settings for nominal cuurent, torque and moment of inertia, but this result in the same message “The settings of the axis are invallid”.

Thanks in advance for the help.

1 Like

Hello Rene,

the message “The settings of the axis are invallid” only tells us that at least one parameter is invalid, not neccessarily a break parameter.

Can you please save the system dump (log books + network command trace) with SDM or at least the Drive log or Network command trace and post it here?
It will show excatly which parameter is invalid.

Hello Martin, thanks for your quick reply! I think I have the requested info: (13.2 KB) (1.9 MB)


The First error can be seen in the Motion LogBook.
These two lines are linked together so you can see that the cause of the Error is ParID42.

Same Error in the DriveLog

Here the Documentation of ParID 42 from APC10 which is also valid for mapp Motion.

In the DriveLog you can see a second error for ParID43

ParID 43

In the Logger there are also alot of temperature sensor settings errors

Please go over these errors step by step. With these help you should now be able to identify possible new ones by yourself. You have to fill in valid data to the Parameter Table. In general no empty fields are allowed, 0.0 can be a valid value for some parameters.

On your gAxisX there is a AxisFeature used which is not valid for an ACOPOS Axis, if its a cam Automat you have to switch the Type of the Feature for example.
Virtual Axis use the common type, ACOPOS uses the ACOPOS type.

CAM Automat - Common / ACOPOS



Hello Michael,

thanks for the reaction. Think because of all errors I missed it and had to much focus on the last general “The settings of the axis are invallid” error. Also after every reset only “The settings of the axis are invallid” comes and not the wrong ParId Error. I solved now almost all errors only the AxisFeature is strange. I have incremental encoders with only A and B pulse, so i have to disable the R pulse of the encoder with ParID 728 putting it to 2. I’m doing this with a AcpParTab. It works well but only after a restart of the plc the error appears on the first axis once, the other axis don’t get this error. After reset the error dissappears. Do you have any idear what this can be? Thanks in advance and already thanks for the rest!

Without more details it is not clear for me what happens there.
If the discussion gets longer it might be a good idea to open a new Thread for this different Topic, so other people will also view it. But first here some ideas:

1. Channel Feature vs. Axis Feature

2. DriveLog
A DriveLog can bring more details, as you can see there the timing of the error and the processing of the AcpParTable. Does the error occure before or after ParID 728 was set.

3. Configuration Review
You may screenshot all configurations which are relevant to this, so we can review it.

  • ParID-Table
  • Feature
  • Axis Configuration were the Feature is linked

4. Versions
Which versions do you use, is it maybe possible to test with a different Version, newer or older.


Hello Michael,

thanks for the help.
As reaction on your suggestions:

  1. I’m using Channel Feature, Axis Feature is resulting in a direct failure and drive will not get ReadyForPowerOn.

  2. DriveLog
    A upload of the drivelog.
    DriveLogSnapShot (1).zip (12.5 KB)


  1. Version
    I’m updating to Automation Studio I4.93, but this is taking a while.

Hope you can already find something in the drivelog for example.

The driveLog seems to not have any error entry. This looks fine. I think there will be some in the Motion Logger in Automation Studio.

But there is one thing i saw in the Pictures…

lets see if this is the last one …


He Michael,

your the best!
Look like that was the case.
Al mistakes where not filled in with values or greyed out. :blush:

Thank you very much!