mappView event binding, layout and content files not loading as graphic


I have installed Automation Studio on a new laptop with Windows 11. I can not open the content pages, the layout pages or the event binding files as graphic, as they just keep on loading, see picture. It does not matter if I open the AS mappView sample project, create a new project or use a project that I’ve developed on my previous laptop. I can open the relevant file types text still.

If the page is open when I close AS, so that it wants to open automatically when I start AS again I get the warning “The mapp View object model is not yet ready. The Event Binding set could not be loaded automatically” and “The mapp View object model is not yet ready. The content could not be loaded automatically”.

I have uninstalled and installed AS again as well as tried both mappView 5.16.1 and 5.25.2.

Has anyone else had this issue and solved it? Thanks in advance!

Picture of the warning message:

Hi Almida,

I’ve seen this error when I open a complicated visualization before the software has fully loaded, but I haven’t seen it persist before unless there is an error in one of the files (i.e. caused by manually editing the xml file and making a typo).

When you open your projects, do all of the tabs (contents, etc.) you have open automatically? Automation Studio keeps track of the items you have open so that it can reopen your windows when you reopen the project. However, I wonder if this is causing many tabs to open before the software has fully loaded.

The first thing I’d recommend is going to Tools → Options and changing the startup behavior (i.e. to “Show start page” instead of “Open last opened project”):


This is more of a personal preference, but it can sometimes be annoying that a project loads immediately when starting the software before you can choose which project you want to open, and this will ensure that the software has a chance to fully load before it tries to open your mappView files.

Next, open one of your projects and close all open tabs with Window → Close All. Then close your project and reopen it. Wait for Automation Studio to fully load (you’ll see some messages appear in the Output window as it opens) and then open a content. Does it load correctly or are there still problems?

Hi Marcus,

I don’t believe it’s a typo since I haven’t made any changes to Automation Studio’s sample program (I’m trying with mvHighlights_5_24) and all of the projects work as they are on my other laptop.

I changed the settings to “Show start page” as you suggested, and reopened the projects with the same result. It keeps on loading forever, unfortunately.

Hello, Almida da val

As a test, I suggest you update the AS version to the latest SP version.

And try again

1 Like

Hi Wenbo,

Thanks for the suggestion, but that didn’t make a difference either… :upside_down_face:

The problem is solved. Right clicking and opening as administrator solved the issue!