Module version V1.09


I’m trying to download the Program but its appearing this error

"Fatal error: Module runtime. Version mismatch. Theo time of version of this module us V1.09.1
Its ccepted only from V1.09 UP to V1.09 in dependency of Module arsyatem.

Simone can help me


Hello @eduardo.oliveira ,

Which version of Automation Studio are you currently using? (Menu → Help → About Automation Studio)? This helps to better guide you through menus.

The message tells that the module “runtime” is set to only work with “arsystem” of version 1.09 but not with version 1.09.1. Both modules are B&R programmed modules - you can’t change or set this yourself.

Because of that one more question: are you sure you have got the correct project matching the original program of this machine?

During your attempt to download to the PLC, is the status showing “RUN” in the right lower status bar of Automation Studio?

  • If yes, you try to find the button “Stop Target”
    ** program execution is stopped and the Status bar indication should change to “Service”
  • now try again to download
  • after that, the easiest is to power off and power on the CP340, it should then start into “Run” again.
    ** alternatively you can try a “warm restart” of your PLC.

If the problem persists you might want to right click on the CP340 in the hardware tree and find “Open Logger”. You should be able to save the logger as a file and maybe attach it here.

Let us hear about your progress

Hello @hasta

I’m using automation studio V2.7 Runtime V2.95.

We are using a PLC with a CP 340 for 2005 version. The flash card lost files and we don’t have a backup, and asked for help to the manufacturer…
They don’t have the original backup too, but send a backup from a similar machine.

It’s not the same project, but similar.

The CPU340 is running, but appear an error too (it’s the initial problem that we asked for help to the manufacturer)

CP 340

Hi Eduardo,

Have you tried pulling the logbook to see why the CP340 is in an error state (service mode)? I would suggest to do this before transferring the project. If the project that you have from the OEM is not the exact project that matches your machine, then it might not solve the problem. In addition, new problems could be introduced. Therefore, transfer at your own risk.

Here are the steps to obtain the log file via a serial connection and without AS (in case you are not able to pull the logbook from AS):

  1. Download the B&R Service Utility from the following link:
    BR Service Utility | B&R Industrial Automation

  2. Install the VC++ Redistributable Package from Microsoft from the following link (if you don’t already have it installed). Make sure to restart your laptop after installing this package.
    Latest supported Visual C++ Redistributable downloads | Microsoft Learn

  3. Make or acquire an RS232 serial cable (null-modem). The required pinout is shown below.

  1. Run the B&R Service Utility (brServiceUtility_v14.exe).

  2. Click OK to the initial welcome pop-up.

  3. Set the connection type to “Serial” (this is the default value) and click OK.

  4. Select the COM port of your serial port or USB-to-serial adaptor. The COM port in use can be found in the Device Manager.

  5. Select “Save Error Logbook” (this is the default value) and click OK.

  6. Choose a download location. Note that the folder that you save the logbook to must already exist (you cannot create a new folder with this window). Also be sure to include the trailing backslash.

  7. Choose a file format for the log file and click OK.

  8. You can then share the log file here and we can help you interpret it, or you can contact your local Support team for direct assistance.

Hi @eduardo.oliveira,

Due to one month of inactivity, this post will be marked as solved. If you would still like assistance on this topic, please add a new reply with the latest status :slight_smile: