SafeDesigner communication via Site manager

Hello B&R world,

I have tried to remote control a safe designer project through link manager but can’t connect. The connection is tested and perfect and working with the grey / AS.

The project is running on the machine but I need to download an update (local engineer on site present for safety reasons of course).

I haven’t changed the server communication port for safeDesigner to safeLogic communications, its default at 50000.

Do I need to open this port through the site manager? If so could someone give an example of how to do this. I did find in the help that 50000 and 51000 are “enabled”:

GUID: a4164439-9a3e-40d7-bb44-299c127d6d70

We set the site manager’s up locally without the use of AS as we have multiple machines connected to the same site manager.

Using B&R hosted service.

Any help is much appreciated.

Thanks
Shaun

PLC: PPC2200 AL14
AS: 4.12.2.93
Safety CPU: SLX910 (FW 2.4.1.1)
mappSafety: 5.23.0
AR: G4.93

SafeDESIGNER 5.23.0.0
Version 5.23.0.0.2593.0

SafeDESIGNER Core B&R Industrial Automation GmbH 3.60
This application was tested on:
Windows 7 SP 1
Windows 8
Windows 8.1
Windows 10

Localization Package 3.60
MUI Translation files

Safety Compiler 2 B&R Industrial Automation GmbH 1.20.96.0
Second safety compiler path

Hardware Configurator 3.60
Hardware configurator

Simulation 2.8
Simulation files:
EasySim Safety 2.8 Build 2
EasySim HNF 2.8 Build 2

Project Comparer 2.0.0.0
Project Comparer files

SAFERGID B&R Industrial Automation GmbH 1.62.21.0
SAFERGRID files

Hello Shaun,

To connect from SafeDESIGNER to a SafePLC over SRM, you will need to open the ports in your device agent.
For the connection from SafeDESIGNER, you need to open port 50000 (assuming you left it at default). This will enable the connection via the SafePLC icon in the toolbar and diagnostic tools like the watch window or the variable status window.

For connection via the Remote Control (what you will be using to perform acknowledgements, download the program, etc), you need to open port 52000 (assuming that you don’t have multiple SafeDOMAINs in your project).

To do this, you will need to add these ports to the “Extra TCP ports” section of your B&R Device Agent

2 Likes

Hi Andrew,

Thank you so much for your quick reply!

I’ll give this a go.

Thanks :smiley:

1 Like

Shouldn’t it be “port 50000” instead of “port 5000” ? :nerd_face:

1 Like

Yes, you’re correct! Thanks, I’ve edited my response

1 Like

It is necessary to fill extra TCP ports without SPACE after COMMA, otherwise error appears.
Expample for run mappCockpit,mappView on port 8084,81 is:

2 Likes