Problem with remote pc and vnc server

Everything stopped working when I set the same IP address to the remote PC and the T50 panel. Now only the T50 panel communicates with the X20 1584 CPU. The remote PC no longer communicates through REALVNC VIEWER with the CPU.

Previously PC AND PANEL T50 were in range with CPU but not equal and everything worked correctly.

But when doing a test and putting the same IP on the remote PC and PANEL T50 THE REMOTE PC no longer communicates, PANEL T50 does communicate. REMOTE PC with REALVNC VIEWER.

Any solution to this?
Thank you.


It is invalid to have two different endpoints with the exact same IP address in the same network.
So if you have set the same IP for both the PC and the T50, it will not work.

Hello Andrew.

I want to go back to the previous situation of being able to communicate with a remote PC, disconnecting PANEL T50 from the ethernet network.

I disconnect the T50 panel from the ethernet network and I can’t connect with the remote PC to the cpu through REALVNC VIEWER

All this happens after the anomaly of putting the same IP address on the remote PC and Panel T 50.

What reset should I do so that I can reconnect with a remote PC with a CPU without connecting PANEL T50 to the ethernet network?

Reset to the PC or CPU?

Thank you

I would recommend restarting the remote PC. It is likely that the RealVNC client device has the T50 in its ARP cache.

Thank you Andrew.

I will opt to uninstall REALVNC and reinstall it. Does this also help to clear the cache? I can’t/want to restart the PC because of the OPC server that is running.

Thank you Andrew.

Hi Julian, can you share with us printscreen of your configuration, I mean VNC server and IP address of PLC, T50 VNC and its ethernet configuration and your remote PC ethernet configuration? What kind of error message do you receive at remote PC? Do you have anything in the logger on PLC side? Can you ping T50 and PLC from your remote PC? has anything change on your remote PC, I mean new antivirus, firewall settings, but also in RealVNC viewer?

It happens that when I put the same ip on T50 and on a remote PC but always disconnecting one of the two from the ethernet network, the one that is connected to the ethernet network obviously works for me. But if I physically disconnect the one I have working (T50 or PC) and then connect the other terminal, the latter no longer communicates with the PLC, it doesn’t matter if it’s one or the other (PC or T50). With the difference that on a remote PC I can clear the REALVNC cache. But now the one that doesn’t communicate to me is the T50. It’s as if the IPs were recorded on the PC and when I connected to the T50 the PLC knew that I have been connected to the remote PC and then it won’t let me connect even though the remote PC is already disconnected.

Please help. Thank You

For me it sounds weird, to be honest. I can only imagine that problem is that PLC VNC server has configured one client as maximum number of parallelly connected clients and the connection is not interrupted properly. But this solves PLC restart. So my suggestions would be:

a) restart PLCs and maybe T50 as well.
b) do not use same IP address for remote PC and T50 if you do not have special reason for that (these are both VNC clients, so they do not need to have the same IP address to connect to same VNC server).
c) check maximum number of VNC clients that can connect to VNC server and if possible increase the number to value higher than 1.

Everything solved.

I need to use the same ip in T50 and on a remote PC because I don’t have the original source codes I can’t know how the VNC server is configured

It happens that if I put different ip addresses in T50 and remote PC, alarm appears in the third-party SCADA (allen bradley) with third-party OPC server also (schneider), the alarm in the SCADA arises because you understand that the T50 panel is not connected, I solve this by integrating everything in a switch (remote pc, T50 and PLC) in this case everything is connected the alarm does not appear but on the remote PC I can manipulate all the variables except the on and off of the computer that are long pulsation variables for more than 5 seconds, all the other variables work except those of on and off.

I guess this can only be corrected if I had the iriginal codes, but I don’t have them.

At the moment it works for me this way because the utility is not to work with remote PC and t50 at the same time, it is only for when t50 panel is unusable then to be able to work with remote PC by disconnecting the panel.

Any other suggestions would be very welcome. At the moment I’m still with the same thing. Thank you all.

1 Like

Ok. Since you are obviously limited by original configuration, there is nothing more we can do for you. I think if you need to change it, you have to contact company that delivery to you this solution. So please mark this question as a finished and feel free to ask any time if you have any new question :slight_smile:

1 Like